cve.bz

CVE-2024-21733

5.3 mediumEPSS 14%

Medium (5.3) in apache tomcat. EPSS 14% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-coyote 8.5.64, 9.0.44.

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Severity

CVSS 3.1

5.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
14% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
CWE
CWE-209
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f4qf-m5gf-8jm8Mavenorg.apache.tomcat:tomcat-coyote>=9.0.0-M11 <9.0.449.0.44
GHSA-f4qf-m5gf-8jm8Mavenorg.apache.tomcat.embed:tomcat-embed-core>=8.5.7 <8.5.648.5.64
GHSA-f4qf-m5gf-8jm8Mavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.0-M11 <9.0.449.0.44
GHSA-f4qf-m5gf-8jm8Mavenorg.apache.tomcat:tomcat-coyote>=8.5.7 <8.5.648.5.64
GHSA-f4qf-m5gf-8jm8Mavenorg.apache.tomcat.experimental:tomcat-embed-programmatic>=9.0.43 <9.0.449.0.44

References

Check your stackJSON