cve.bz

CVE-2024-21520

2.1 lowEPSS 1.1%

Low (2.1). EPSS 1.1% chance of exploitation in the next 30 days. Fixed in djangorestframework 3.15.2.

Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.

Severity

CVSS 4.0

2.1 low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gw84-84pc-xp82PyPIdjangorestframework<3.15.23.15.2
PYSEC-2026-1304PyPIdjangorestframework<3.15.23.15.2

References

Check your stackJSON