cve.bz

CVE-2024-21508

9.8 criticalEPSS 2.6%

Critical (9.8). EPSS 2.6% chance of exploitation in the next 30 days. Fixed in mysql2 3.9.4.

Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due to improper validation of the supportBigNumbers and bigNumberStrings values.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.6% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fpw7-j2hg-69v5npmmysql2<3.9.43.9.4

References

Check your stackJSON