Critical (9.8). EPSS 6.0% chance of exploitation in the next 30 days. Fixed in invokeai 5.4.3rc1, 5.4.3rc2.
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
Severity
CVSS 3.0
9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
6.0% chance of exploitation in the next 30 days; higher than 93% of CVEs (scores of 2026-10-31)