cve.bz

CVE-2024-11079

5.5 mediumEPSS 0.5%

Medium (5.5). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in ansible-core 2.16.14rc1, 2.17.7rc1, 2.18.1rc1.

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-99w6-3xph-cx78PyPIansible-core>=2.18.0b1 <2.18.1rc12.18.1rc1
GHSA-99w6-3xph-cx78PyPIansible-core>=2.17.0b1 <2.17.7rc12.17.7rc1
GHSA-99w6-3xph-cx78PyPIansible-core<2.16.14rc12.16.14rc1
PYSEC-2026-1123PyPIansible-core<2.16.14rc1
>=2.17.0b1 <2.17.7rc1
>=2.18.0b1 <2.18.1rc1
2.16.14rc1, 2.17.7rc1, 2.18.1rc1

References

Check your stackJSON