Low (3.3) in pypa pip. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in pip 23.3.
When installing a package from a Mercurial VCS URL (ie "pip install
hg+...") with pip prior to v23.3, the specified Mercurial revision could
be used to inject arbitrary configuration options to the "hg clone"
call (ie "--config"). Controlling the Mercurial configuration can modify
how and which repository is installed. This vulnerability does not
affect users who aren't installing from Mercurial.
Severity
CVSS 3.1
3.3 low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)