cve.bz

CVE-2023-51518

9.8 criticalEPSS 1.2%

Critical (9.8) in apache james. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.james:james-server 3.7.5, 3.8.1.

Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of untrusted data. Given a deserialisation gadjet, this could be leveraged as part of an exploit chain that could result in privilege escalation. Note that by default JMX endpoint is only bound locally. We recommend users to:  - Upgrade to a non-vulnerable Apache James version  - Run Apache James isolated from other processes (docker - dedicated virtual machine)  - If possible turn off JMX

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-px7w-c9gw-7gj3Mavenorg.apache.james:james-server<3.7.53.7.5
GHSA-px7w-c9gw-7gj3Mavenorg.apache.james:james-server>=3.8.0 <3.8.13.8.1

References

Check your stackJSON