cve.bz

CVE-2023-48291

4.3 mediumEPSS 1.8%

Medium (4.3) in apache airflow. EPSS 1.8% chance of exploitation in the next 30 days. Fixed in apache-airflow 2.8.0.

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2  Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Severity

CVSS 3.1

4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
1.8% chance of exploitation in the next 30 days; higher than 78% of CVEs (scores of 2026-10-31)
CWE
CWE-668
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8f57-wcmg-4jmhPyPIapache-airflow<2.8.02.8.0
PYSEC-2023-265PyPIapache-airflow<2.8.02.8.0

References

Check your stackJSON