cve.bz

CVE-2023-47265

5.4 mediumEPSS 1.3%

Medium (5.4) in apache airflow. EPSS 1.3% chance of exploitation in the next 30 days. Fixed in apache-airflow 2.8.0b1.

Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.3% chance of exploitation in the next 30 days; higher than 71% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pxch-wr7m-rwxjPyPIapache-airflow>=2.6.0 <2.8.0b12.8.0b1
PYSEC-2023-264PyPIapache-airflow>=2.6.0 <2.8.0b12.8.0b1

References

Check your stackJSON