cve.bz

CVE-2023-46801

8.8 highEPSS 1.2%

High (8.8) in apache linkis. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.linkis:linkis-datasource 1.6.0.

In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.  We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 68% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-jjvc-v8gw-5255Mavenorg.apache.linkis:linkis-datasource>=1.4.0 <1.6.01.6.0

References

Check your stackJSON