cve.bz

CVE-2023-46589

7.5 highEPSS 2.7%

High (7.5) in apache tomcat. EPSS 2.7% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-catalina 10.1.16, 11.0.0-M11, 8.5.96.

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
2.7% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
CWE
CWE-444
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat:tomcat-catalina>=11.0.0-M1 <11.0.0-M1111.0.0-M11
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat:tomcat-catalina>=10.1.0-M1 <10.1.1610.1.16
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat:tomcat-catalina>=9.0.0-M1 <9.0.839.0.83
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat:tomcat-catalina>=8.5.0 <8.5.968.5.96
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.0-M1 <11.0.0-M1111.0.0-M11
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.0-M1 <10.1.1610.1.16
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.0-M1 <9.0.839.0.83
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat.embed:tomcat-embed-core>=8.5.0 <8.5.968.5.96
GHSA-fccv-jmmp-qg76Mavenorg.apache.tomcat:tomcat-coyote>=11.0.0-M1 <11.0.0-M1111.0.0-M11

References

Check your stackJSON