cve.bz

CVE-2023-46131

7.5 highEPSS 0.7%

High (7.5) in grails grails. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in org.grails:grails-databinding 3.3.17, 4.1.3, 5.3.4.

Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)
CWE
CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3pjv-r7w4-2cf5Mavenorg.grails:grails-databinding>=6.0.0 <6.1.06.1.0
GHSA-3pjv-r7w4-2cf5Mavenorg.grails:grails-databinding>=5.0.0 <5.3.45.3.4
GHSA-3pjv-r7w4-2cf5Mavenorg.grails:grails-databinding>=4.0.0 <4.1.34.1.3
GHSA-3pjv-r7w4-2cf5Mavenorg.grails:grails-databinding>=2.0.0 <3.3.173.3.17

References

Check your stackJSON