cve.bz

CVE-2023-45144

9.6 criticalEPSS 1.2%

Critical (9.6) in xwiki oauth identity. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in com.xwiki.identity-oauth:identity-oauth-ui 1.6.

com.xwiki.identity-oauth:identity-oauth-ui is a package to aid in building identity and service providers based on OAuth authorizations. When a user logs in via the OAuth method, the identityOAuth parameters sent in the GET request is vulnerable to cross site scripting (XSS) and XWiki syntax injection. This allows remote code execution via the groovy macro and thus affects the confidentiality, integrity and availability of the whole XWiki installation. The issue has been fixed in Identity OAuth version 1.6. There are no known workarounds for this vulnerability and users are advised to upgrade.

Severity

CVSS 3.1

9.6 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWEs
CWE-79, CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h2rm-29ch-wfmhMavencom.xwiki.identity-oauth:identity-oauth-ui>=1.0 <1.61.6

References

Check your stackJSON