cve.bz

CVE-2023-43645

5.9 mediumEPSS 0.9%

Medium (5.9) in openfga openfga. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in github.com/openfga/openfga 1.3.2.

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA is vulnerable to a denial of service attack when certain Check calls are executed against authorization models that contain circular relationship definitions. When the call is made, it's possible for the server to exhaust resources and die. Users are advised to upgrade to v1.3.2 and update any offending models. There are no known workarounds for this vulnerability. Note that for models which contained cycles or a relation definition that has the relation itself in its evaluation path, checks and queries that require evaluation will no longer be evaluated on v1.3.2+ and will return errors instead. Users who do not have cyclic models are unaffected.

Severity

CVSS 3.1

5.9 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-835
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2hm9-h873-pgqhGogithub.com/openfga/openfga<1.3.21.3.2
GO-2023-2084Gogithub.com/openfga/openfga<1.3.21.3.2

References

Check your stackJSON