cve.bz

CVE-2023-37415

8.8 highEPSS 1.6%

High (8.8) in apache apache-airflow-providers-apache-hive. EPSS 1.6% chance of exploitation in the next 30 days. Fixed in apache-airflow-providers-apache-hive 6.1.2.

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider. Patching on top of CVE-2023-35797 Before 6.1.2 the proxy_user option can also inject semicolon. This issue affects Apache Airflow Apache Hive Provider: before 6.1.2. It is recommended updating provider version to 6.1.2 in order to avoid this vulnerability.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.6% chance of exploitation in the next 30 days; higher than 75% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4q2q-q5pw-2342PyPIapache-airflow-providers-apache-hive<6.1.26.1.2
PYSEC-2026-1139PyPIapache-airflow-providers-apache-hive<6.1.26.1.2

References

Check your stackJSON