Critical (9.8) in apache apache-airflow-providers-apache-hive. EPSS 2.8% chance of exploitation in the next 30 days. Fixed in apache-airflow-providers-apache-hive 6.1.1.
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider.
This issue affects Apache Airflow Apache Hive Provider: before 6.1.1.
Before version 6.1.1 it was possible to bypass the security check to RCE via
principal parameter. For this to be exploited it requires access to modifying the connection details.
It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.8% chance of exploitation in the next 30 days; higher than 86% of CVEs (scores of 2026-10-31)