cve.bz

CVE-2023-35042

9.8 criticalEPSS 45%

Critical (9.8) in geoserver geoserver. EPSS 45% chance of exploitation in the next 30 days. Fixed in org.geoserver:gs-wms 2.18.6, 2.19.6, 2.20.4.

GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via java.lang.Runtime.getRuntime().exec in wps:LiteralData within a wps:Execute request, as exploited in the wild in June 2023. NOTE: the vendor states that they are unable to reproduce this in any version.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
45% chance of exploitation in the next 30 days; higher than 98% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wms<2.18.62.18.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wfs<2.18.62.18.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wms>=2.19.0 <2.19.62.19.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wfs>=2.19.0 <2.19.62.19.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wms>=2.20.0 <2.20.42.20.4
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wfs>=2.20.0 <2.20.42.20.4
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wps<2.18.62.18.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wps>=2.19.0 <2.19.62.19.6
GHSA-59x6-g4jr-4hxcMavenorg.geoserver:gs-wps>=2.20.0 <2.20.42.20.4

References

Check your stackJSON