cve.bz

CVE-2023-34442

3.3 lowEPSS 0.4%

Low (3.3) in apache camel. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.apache.camel:camel-jira 3.14.9, 3.18.8, 3.20.6.

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3. Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1

Severity

CVSS 3.1

3.3 low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 37% of CVEs (scores of 2026-10-31)
CWE
CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6g2w-257v-3c9fMavenorg.apache.camel:camel-jira>=3.0.0-M3 <3.14.93.14.9
GHSA-6g2w-257v-3c9fMavenorg.apache.camel:camel-jira>=3.15.0 <3.18.83.18.8
GHSA-6g2w-257v-3c9fMavenorg.apache.camel:camel-jira>=3.20.0 <3.20.63.20.6
GHSA-6g2w-257v-3c9fMavenorg.apache.camel:camel-jira>=4.0.0-M1 <4.0.0-RC14.0.0-RC1

References

Check your stackJSON