cve.bz

CVE-2023-34103

5.4 mediumEPSS 0.6%

Medium (5.4) in avohq avo. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in avo 2.33.3.

Avo is an open source ruby on rails admin panel creation framework. In affected versions some avo fields are vulnerable to Cross Site Scripting (XSS) when rendering html based content. Attackers do need form edit privilege in order to successfully exploit this vulnerability, but the results are stored and no specific timing is required. This issue has been addressed in commit `7891c01e` which is expected to be included in the next release of avo. Users are advised to configure CSP headers for their application and to limit untrusted user access as a mitigation.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5cr9-5jx3-2g39RubyGemsavo<2.33.32.33.3
GHSA-5cr9-5jx3-2g39RubyGemsavo>=3.0.0.pre1 <=3.0.0.pre12no fix published

References

Check your stackJSON