cve.bz

CVE-2023-33246

9.8 criticalKEVEPSS 97%

Critical (9.8) in Apache RocketMQ. In CISA KEV since 2023-09-06. EPSS 97% chance of exploitation in the next 30 days. Fixed in org.apache.rocketmq:rocketmq-broker 5.1.1.

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
97% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CISA KEV
listed 2023-09-06, due 2023-09-27
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x3cq-8f32-5f63Mavenorg.apache.rocketmq:rocketmq-broker>=5.0.0 <5.1.15.1.1
GHSA-x3cq-8f32-5f63Mavenorg.apache.rocketmq:rocketmq-namesrv>=4.0.0 <4.9.64.9.6
GHSA-x3cq-8f32-5f63Mavenorg.apache.rocketmq:rocketmq-controller>=5.0.0 <5.1.15.1.1
GHSA-x3cq-8f32-5f63Mavenorg.apache.rocketmq:rocketmq-namesrv>=5.0.0 <5.1.15.1.1

References

Check your stackJSON