cve.bz

CVE-2023-33189

9.8 criticalEPSS 0.9%

Critical (9.8) in pomerium pomerium. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in github.com/pomerium/pomerium 0.17.4, 0.18.1, 0.19.2.

Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-285
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium>=0.22.0 <0.22.20.22.2
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium>=0.21.0 <0.21.40.21.4
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium>=0.20.0 <0.20.10.20.1
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium>=0.19.0 <0.19.20.19.2
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium>=0.18.0 <0.18.10.18.1
GHSA-pvrc-wvj2-f59pGogithub.com/pomerium/pomerium<0.17.40.17.4
GO-2023-1800Gogithub.com/pomerium/pomerium<0.17.4
>=0.18.0 <0.18.1
>=0.19.0 <0.19.2
>=0.20.0 <0.20.1
>=0.21.0 <0.21.4
>=0.22.0 <0.22.2
0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4, 0.22.2

References

Check your stackJSON