cve.bz

CVE-2023-31543

9.8 criticalEPSS 1.2%

Critical (9.8) in pipreqs project pipreqs. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in pipreqs 0.4.12.

A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-427
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v4f4-23wc-99mhPyPIpipreqs>=0.3.0 <0.4.120.4.12
PYSEC-2023-99PyPIpipreqs>=0.3.0 <0.4.120.4.12

References

Check your stackJSON