cve.bz

CVE-2023-31098

9.8 criticalEPSS 1.2%

Critical (9.8) in apache inlong. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.inlong:manager-pojo 1.47.0.

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0.  When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWE
CWE-521
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w3wr-gmwf-r333Mavenorg.apache.inlong:manager-pojo>=1.1.0 <1.47.01.47.0

References

Check your stackJSON