cve.bz

CVE-2023-31065

9.1 criticalEPSS 1.2%

Critical (9.1) in apache inlong. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.inlong:manager-pojo 1.7.0.

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0.  An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-613
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-757p-7hp5-pqmrMavenorg.apache.inlong:manager-pojo>=1.4.0 <1.7.01.7.0
GHSA-757p-7hp5-pqmrMavenorg.apache.inlong:manager-dao>=1.4.0 <1.7.01.7.0
GHSA-757p-7hp5-pqmrMavenorg.apache.inlong:manager-web>=1.4.0 <1.7.01.7.0
GHSA-757p-7hp5-pqmrMavenorg.apache.inlong:manager-service>=1.4.0 <1.7.01.7.0

References

Check your stackJSON