cve.bz

CVE-2023-29234

9.8 criticalEPSS 7.4%

Critical (9.8) in apache dubbo. EPSS 7.4% chance of exploitation in the next 30 days. Fixed in org.apache.dubbo:dubbo 3.1.11, 3.2.5.

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4. Users are recommended to upgrade to the latest version, which fixes the issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
7.4% chance of exploitation in the next 30 days; higher than 94% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6x49-w35h-wqrjMavenorg.apache.dubbo:dubbo>=3.1.0 <3.1.113.1.11
GHSA-6x49-w35h-wqrjMavenorg.apache.dubbo:dubbo>=3.2.0 <3.2.53.2.5

References

Check your stackJSON