Critical (9.8) in geokit geokit-rails. EPSS 3.8% chance of exploitation in the next 30 days. Fixed in geokit-rails 2.5.0.
Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value.
**Note:**
An attacker can use this vulnerability to execute commands on the host system.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.8% chance of exploitation in the next 30 days; higher than 90% of CVEs (scores of 2026-10-31)