Medium (5.3) in graphql graphql. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in graphql 16.8.1.
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
**Note:** It was not proven that this vulnerability can crash the process.
Severity
CVSS 3.1
5.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)