cve.bz

CVE-2023-25574

9.8 criticalEPSS 0.4%

Critical (9.8) in jupyter lti jupyterhub authenticator. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in jupyterhub-ltiauthenticator 1.4.0.

`jupyterhub-ltiauthenticator` is a JupyterHub authenticator for learning tools interoperability (LTI). LTI13Authenticator that was introduced in `jupyterhub-ltiauthenticator` 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request. Only users that has configured a JupyterHub installation to use the authenticator class `LTI13Authenticator` are affected. `jupyterhub-ltiauthenticator` version 1.4.0 removes LTI13Authenticator to address the issue. No known workarounds are available.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWE
CWE-347
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mcgx-2gcr-p3hpPyPIjupyterhub-ltiauthenticator>=1.3.0 <1.4.01.4.0
PYSEC-2025-120PyPIjupyterhub-ltiauthenticator<=1.3.0no fix published

References

Check your stackJSON