cve.bz

CVE-2023-25564

8.2 highEPSS 1.9%

High (8.2) in gss-ntlmssp project gss-ntlmssp. EPSS 1.9% chance of exploitation in the next 30 days.

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.

Severity

CVSS 3.1

8.2 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
1.9% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)
CWE
CWE-787
Published
Modified
Record from
the NVD, synced

Affected

References

Check your stackJSON