cve.bz

CVE-2023-25173

7.8 highEPSS 0.5%

High (7.8) in linuxfoundation containerd. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd 1.5.18, 1.6.18.

containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hmfx-3pcx-653pGogithub.com/containerd/containerd<1.5.181.5.18
GHSA-hmfx-3pcx-653pGogithub.com/containerd/containerd>=1.6.0 <1.6.181.6.18
GO-2023-1574Gogithub.com/containerd/containerd<1.5.18
>=1.6.0 <1.6.18
1.5.18, 1.6.18

References

Check your stackJSON