cve.bz

CVE-2023-25168

8.2 highEPSS 1.0%

High (8.2) in pterodactyl wings. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in github.com/pterodactyl/wings 1.11.4, 1.7.4.

Wings is Pterodactyl's server control plane. This vulnerability can be used to delete files and directories recursively on the host system. This vulnerability can be combined with `GHSA-p8r3-83r8-jwj5` to overwrite files on the host system. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. This vulnerability has been resolved in version `v1.11.4` of Wings, and has been back-ported to the 1.7 release series in `v1.7.4`. Anyone running `v1.11.x` should upgrade to `v1.11.4` and anyone running `v1.7.x` should upgrade to `v1.7.4`. There are no known workarounds for this issue.

Severity

CVSS 3.1

8.2 high
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:H
EPSS
1.0% chance of exploitation in the next 30 days; higher than 61% of CVEs (scores of 2026-10-31)
CWE
CWE-59
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-66p8-j459-rq63Gogithub.com/pterodactyl/wings<1.7.41.7.4
GHSA-66p8-j459-rq63Gogithub.com/pterodactyl/wings>=1.11.0 <1.11.41.11.4
GO-2023-1555Gogithub.com/pterodactyl/wings<1.7.4
>=1.11.0 <1.11.4
1.7.4, 1.11.4

References

Check your stackJSON