cve.bz

CVE-2023-25153

5.5 mediumEPSS 0.4%

Medium (5.5) in linuxfoundation containerd. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd 1.5.18, 1.6.18.

containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 30% of CVEs (scores of 2026-10-31)
CWE
CWE-770
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-259w-8hf6-59c2Gogithub.com/containerd/containerd<1.5.181.5.18
GHSA-259w-8hf6-59c2Gogithub.com/containerd/containerd>=1.6.0 <1.6.181.6.18
GO-2023-1573Gogithub.com/containerd/containerd<1.5.18
>=1.6.0 <1.6.18
1.5.18, 1.6.18

References

Check your stackJSON