cve.bz

CVE-2023-22665

5.4 mediumEPSS 1.3%

Medium (5.4) in apache jena. EPSS 1.3% chance of exploitation in the next 30 days. Fixed in org.apache.jena:jena 4.8.0.

There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.3% chance of exploitation in the next 30 days; higher than 71% of CVEs (scores of 2026-10-31)
CWE
CWE-917
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xgh5-gwq5-rpx8Mavenorg.apache.jena:jena<4.8.04.8.0

References

Check your stackJSON