cve.bz

CVE-2023-20873

9.8 criticalEPSS 1.1%

Critical (9.8) in vmware spring boot. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in org.springframework.boot:spring-boot-actuator-autoconfigure 2.5.15, 2.6.15, 2.7.11.

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g5h3-w546-pj7fMavenorg.springframework.boot:spring-boot-actuator-autoconfigure>=3.0.0 <3.0.63.0.6
GHSA-g5h3-w546-pj7fMavenorg.springframework.boot:spring-boot-actuator-autoconfigure>=2.7.0 <2.7.112.7.11
GHSA-g5h3-w546-pj7fMavenorg.springframework.boot:spring-boot-actuator-autoconfigure>=2.6.0 <2.6.152.6.15
GHSA-g5h3-w546-pj7fMavenorg.springframework.boot:spring-boot-actuator-autoconfigure<2.5.152.5.15

References

Check your stackJSON