cve.bz

CVE-2023-0872

8.0 highEPSS 3.3%

High (8.0) in opennms. EPSS 3.3% chance of exploitation in the next 30 days. Fixed in org.opennms:opennms-webapp-rest 32.0.2.

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Severity

CVSS 3.1

8.0 high
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
3.3% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-269
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w5gq-xrrp-3fxfMavenorg.opennms:opennms-webapp-rest>=31.0.8 <32.0.232.0.2

References

Check your stackJSON