CVE-2022-4892

A vulnerability was found in MyCMS. It has been classified as problematic. This affects the function build_view of the file lib/gener/view.php of the component Visitors Module. The manipulation of the argument original/converted leads to cross site scripting. It is possible to initiate the attack remotely. The name of the patch is d64fcba4882a50e21cdbec3eb4a080cb694d26ee. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-218895.
References
Link Resource
https://vuldb.com/?ctiid.218895 Permissions Required Third Party Advisory
https://github.com/andrzuk/MyCMS/commit/d64fcba4882a50e21cdbec3eb4a080cb694d26ee Patch Third Party Advisory
https://vuldb.com/?id.218895 Permissions Required Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:mycms_project:mycms:*:*:*:*:*:*:*:*

History

25 Jan 2023, 20:56

Type Values Removed Values Added
First Time Mycms Project
Mycms Project mycms
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 6.1
References (MISC) https://vuldb.com/?id.218895 - (MISC) https://vuldb.com/?id.218895 - Permissions Required, Third Party Advisory
References (MISC) https://github.com/andrzuk/MyCMS/commit/d64fcba4882a50e21cdbec3eb4a080cb694d26ee - (MISC) https://github.com/andrzuk/MyCMS/commit/d64fcba4882a50e21cdbec3eb4a080cb694d26ee - Patch, Third Party Advisory
References (MISC) https://vuldb.com/?ctiid.218895 - (MISC) https://vuldb.com/?ctiid.218895 - Permissions Required, Third Party Advisory
CPE cpe:2.3:a:mycms_project:mycms:*:*:*:*:*:*:*:*

19 Jan 2023, 08:15

Type Values Removed Values Added
New CVE

Information

Published : 2023-01-19 08:15

Updated : 2023-01-25 20:56


NVD link : CVE-2022-4892

Mitre link : CVE-2022-4892


JSON object : View

Products Affected

mycms_project

  • mycms
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')