cve.bz

CVE-2022-46870

5.4 mediumEPSS 1.2%

Medium (5.4) in apache zeppelin. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.zeppelin:zeppelin 0.8.2.

An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Zeppelin allows logged-in users to execute arbitrary javascript in other users' browsers. This issue affects Apache Zeppelin before 0.8.2. Users are recommended to upgrade to a supported version of Zeppelin.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 68% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9p8j-hrgf-jc2gMavenorg.apache.zeppelin:zeppelin<0.8.20.8.2

References

Check your stackJSON