cve.bz

CVE-2022-4643

9.8 criticalEPSS 1.8%

A vulnerability was found in docconv up to 1.2.0. It has been declared as critical. This vulnerability affects the function ConvertPDFImages of the file pdf_ocr.go. The manipulation of the argument path leads to os command injection. The attack can be initiated remotely. Upgrading to version 1.2.1 is able to address this issue. The name of the patch is b19021ade3d0b71c89d35cb00eb9e589a121faa5. It is recommended to upgrade the affected component. VDB-216502 is the identifier assigned to this vulnerability.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.8% chance of exploitation in the next 30 days; higher than 78% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6m4h-hfpp-x8cxGogithub.com/sajari/docconv<1.2.11.2.1
GHSA-6m4h-hfpp-x8cxGocode.sajari.com/docconv>=1.1.0 <1.3.51.3.5
GO-2022-1184Gocode.sajari.com/docconv>=1.1.0 <1.3.51.3.5

References

Check your stackJSON