cve.bz

CVE-2022-43756

7.5 highEPSS 0.7%

High (7.5) in suse wrangler. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in github.com/rancher/wrangler 0.7.4-security1, 0.8.11, 0.8.5-security1.

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8fcj-gf77-47mgGogithub.com/rancher/wrangler<0.7.4-security10.7.4-security1
GHSA-8fcj-gf77-47mgGogithub.com/rancher/wrangler>=0.8.0 <0.8.5-security10.8.5-security1
GHSA-8fcj-gf77-47mgGogithub.com/rancher/wrangler>=1.0.0 <1.0.11.0.1
GHSA-8fcj-gf77-47mgGogithub.com/rancher/wrangler>=0.8.6 <0.8.110.8.11
GO-2023-1515Gogithub.com/rancher/wrangler<0.7.4-security1
>=0.8.0 <0.8.5-security1
>=0.8.6 <0.8.11
>=1.0.0 <1.0.1
0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1

References

Check your stackJSON