cve.bz

CVE-2022-43755

9.8 criticalEPSS 1.7%

Critical (9.8) in suse rancher. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in github.com/rancher/rancher 2.6.10, 2.7.1.

A Insufficient Entropy vulnerability in SUSE Rancher allows attackers that gained knowledge of the cattle-token to continue abusing this even after the token was renewed. This issue affects: SUSE Rancher Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
CWE
CWE-331
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8c69-r38j-rpfjGogithub.com/rancher/rancher>=2.6.0 <2.6.102.6.10
GHSA-8c69-r38j-rpfjGogithub.com/rancher/rancher>=2.7.0 <2.7.12.7.1

References

Check your stackJSON