cve.bz

CVE-2022-43718

5.4 mediumEPSS 1.2%

Medium (5.4) in apache superset. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in apache-superset 1.5.3, 2.0.1.

Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-79x5-cv79-49rjPyPIapache-superset<=1.5.2no fix published
GHSA-79x5-cv79-49rjPyPIapache-superset2.0.0no fix published
PYSEC-2026-777PyPIapache-superset<1.5.3
>=2.0.0 <2.0.1
1.5.3, 2.0.1

References

Check your stackJSON