cve.bz

CVE-2022-41957

7.5 highEPSS 1.1%

High (7.5). EPSS 1.1% chance of exploitation in the next 30 days. Fixed in muhammara 2.6.2, 3.4.0.

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWE
CWE-690
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2r7v-cmch-5x26npmhummusall versionsno fix published
GHSA-2r7v-cmch-5x26npmmuhammara>=3.0.0 <3.4.03.4.0
GHSA-2r7v-cmch-5x26npmmuhammara<2.6.22.6.2

References

Check your stackJSON