cve.bz

CVE-2022-41911

7.5 highEPSS 0.4%

High (7.5) in google tensorflow. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. When printing a tensor, we get it's data as a `const char*` array (since that's the underlying storage) and then we typecast it to the element type. However, conversions from `char` to `bool` are undefined if the `char` is not `0` or `1`, so sanitizers/fuzzers will crash. The issue has been patched in GitHub commit `1be74370327`. The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.10.1, TensorFlow 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-31)
CWE
CWE-704
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pf36-r9c6-h97jPyPItensorflow<2.8.42.8.4
GHSA-pf36-r9c6-h97jPyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-pf36-r9c6-h97jPyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
GHSA-pf36-r9c6-h97jPyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-pf36-r9c6-h97jPyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-pf36-r9c6-h97jPyPItensorflow-cpu<2.8.42.8.4
GHSA-pf36-r9c6-h97jPyPItensorflow-gpu<2.8.42.8.4
GHSA-pf36-r9c6-h97jPyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-pf36-r9c6-h97jPyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-1954PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3222PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-939PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON