cve.bz

CVE-2022-41908

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. An input `token` that is not a UTF-8 bytestring will trigger a `CHECK` fail in `tf.raw_ops.PyFunc`. We have patched the issue in GitHub commit 9f03a9d3bafe902c1e6beb105b2f24172f238645. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 43% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mv77-9g28-cwg3PyPItensorflow<2.8.42.8.4
GHSA-mv77-9g28-cwg3PyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-mv77-9g28-cwg3PyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-mv77-9g28-cwg3PyPItensorflow-cpu<2.8.42.8.4
GHSA-mv77-9g28-cwg3PyPItensorflow-gpu<2.8.42.8.4
GHSA-mv77-9g28-cwg3PyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-mv77-9g28-cwg3PyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-mv77-9g28-cwg3PyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
GHSA-mv77-9g28-cwg3PyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-1021PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3217PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3353PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON