cve.bz

CVE-2022-41896

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. If `ThreadUnsafeUnigramCandidateSampler` is given input `filterbank_channel_count` greater than the allowed max size, TensorFlow will crash. We have patched the issue in GitHub commit 39ec7eaf1428e90c37787e5b3fbd68ebd3c48860. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)
CWEs
CWE-1284, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rmg2-f698-wq35PyPItensorflow<2.8.42.8.4
GHSA-rmg2-f698-wq35PyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-rmg2-f698-wq35PyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-rmg2-f698-wq35PyPItensorflow-cpu<2.8.42.8.4
GHSA-rmg2-f698-wq35PyPItensorflow-gpu<2.8.42.8.4
GHSA-rmg2-f698-wq35PyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-rmg2-f698-wq35PyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-rmg2-f698-wq35PyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
GHSA-rmg2-f698-wq35PyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-1035PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3239PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3369PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON