cve.bz

CVE-2022-41893

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. If `tf.raw_ops.TensorListResize` is given a nonscalar value for input `size`, it results `CHECK` fail which can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 888e34b49009a4e734c27ab0c43b0b5102682c56. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-67pf-62xr-q35mPyPItensorflow<2.8.42.8.4
GHSA-67pf-62xr-q35mPyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-67pf-62xr-q35mPyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-67pf-62xr-q35mPyPItensorflow-cpu<2.8.42.8.4
GHSA-67pf-62xr-q35mPyPItensorflow-gpu<2.8.42.8.4
GHSA-67pf-62xr-q35mPyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-67pf-62xr-q35mPyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-67pf-62xr-q35mPyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
GHSA-67pf-62xr-q35mPyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-3118PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3284PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-958PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON