cve.bz

CVE-2022-40023

7.5 highEPSS 2.2%

High (7.5). EPSS 2.2% chance of exploitation in the next 30 days. Fixed in mako 1.2.2.

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
CWE
CWE-1333
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v973-fxgf-6xhpPyPImako<1.2.21.2.2
PYSEC-2022-260PyPImako<1.2.21.2.2

References

Check your stackJSON