cve.bz

CVE-2022-39341

9.8 criticalEPSS 1.1%

Critical (9.8) in openfga openfga. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in github.com/openfga/openfga 0.2.4.

OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWE
CWE-285
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vj4m-83m8-xpw5Gogithub.com/openfga/openfga<0.2.40.2.4
GO-2022-1080Gogithub.com/openfga/openfga<0.2.40.2.4

References

Check your stackJSON