cve.bz

CVE-2022-39299

8.1 highEPSS 4.5%

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.5% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)
CWE
CWE-347
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m974-647v-whv7npmpassport-saml<3.2.23.2.2
GHSA-m974-647v-whv7npmnode-saml<4.0.0-beta.54.0.0-beta.5
GHSA-m974-647v-whv7npm@node-saml/node-saml<4.0.0-beta.54.0.0-beta.5
GHSA-m974-647v-whv7npm@node-saml/passport-saml<4.0.0-beta.34.0.0-beta.3

References

Check your stackJSON