cve.bz

CVE-2022-37734

7.5 highEPSS 2.6%

graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.6% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v62j-cxhh-fq22Mavencom.graphql-java:graphql-java<17.417.4
GHSA-v62j-cxhh-fq22Mavencom.graphql-java:graphql-java>=18.0 <18.318.3

References

Check your stackJSON